您的位置:首页 > 其它

UVA 10361

2015-07-20 20:27 387 查看
A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete the poem yourself. Well, even a computer can do that,
and your task is to write a program which completes them automatically. This will help Lara concentrate on the “action” part of Tomb Raider and not on the “intellectual” part.

Input

The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form

s1<s2>s3<s4>s5
 

where the si are possibly empty, strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots “...”. Lines will we at most 100 characters long.

Output

For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way: c1 is the same as l1 only that the bracket marks “<” and “>” are removed. Line c2
is the same as l2 , except that instead of the three dots the string s4s3s2s5 should appear.

Sample Input

3

ein kind haelt seinen< schn>abel <n>ur

wenn es haengt an der ...

weil wir zu spaet zur<> oma <k>amen

verpassten wir das ...

<d>u <b>ist

...

Sample Output

ein kind haelt seinen schnabel nur

wenn es haengt an der nabel schnur

weil wir zu spaet zur oma kamen

verpassten wir das koma amen

du bist

bu dist

代码#include<stdio.h>
#include<string.h>
#define N 100
int main (){
int i,j,Case,len;
char a
,b
,s
,s1
,s2
,s3
,s4
,s5
;
while(scanf("%d\n",&Case) != EOF){
while(Case--){
gets(a);
gets(b);
len = strlen(a);
for(j = 0,i = 0;a[i] != '<';i++,j++){
s1[j] = a[i];
}
s1[j] = '\0';
for(i = i+1,j = 0;a[i] != '>';i++,j++){
s2[j] = a[i];
}
s2[j] = '\0';
for(i = i+1,j = 0;a[i] != '<';i++,j++){
s3[j] = a[i];
}
s3[j] = '\0';
for(i = i+1,j = 0;a[i] != '>';i++,j++){
s4[j] = a[i];
}
s4[j] = '\0';
for(i = i+1,j = 0;i < len;i++,j++){
s5[j] = a[i];
}
s5[j] = '\0';
for(i = 0,j = 0;b[i] != '.';i++,j++){
s[j] = b[i];
}
s[j] = '\0';
printf("%s%s%s%s%s\n",s1,s2,s3,s4,s5);
printf("%s%s%s%s%s\n",s,s4,s3,s2,s5);

4000
}
}
return 0;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: