您的位置:首页 > 大数据 > 人工智能

hdoj1021Fibonacci Again

2015-07-20 19:12 507 查看

第二个方法是找出的规律。你们可以观察观察。

/*Fibonacci Again

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11,

F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0

1

2

3

4

5

Sample Output

no

no

yes

no

no

no*/

<span style="font-size:18px;"># include<stdio.h>
# define  m 1000001
int f[m];
int main()
{
        int n,i;
        f[0]=7;
        f[1]=11;
        for(i=2;i<=m;i++)
        f[i]=(f[i-1]%3+f[i-2]%3)%3;
        while(scanf("%d",&n)!=EOF)
    {
        if(f
%3==0)
        printf("yes\n");
        else
        printf("no\n");
    }
    return 0;
}</span>


<span style="font-size:18px;">#include<stdio.h>
 main()
 {
  int n;
  while(~scanf("%d",&n))
  {
   if(n%4==2) printf("yes\n");
   else printf("no\n");
  }
 }</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: