您的位置:首页 > 其它

poj 1860 Currency Exchange

2015-07-20 15:40 267 查看
http://poj.org/problem?id=1860

Currency Exchange
Time Limit:1000MS Memory Limit:30000KB 64bit IO Format:%I64d & %I64u
Submit Status

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies.
Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges,
and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative
sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description
of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations
will be less than 10 4.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00


Sample Output

YES


提示:关键在于反向利用Bellman-Ford算法

题目大意

有多种汇币,汇币之间可以交换,这需要手续费,当你用100A币交换B币时,A到B的汇率是29.75,手续费是0.39,那么你可以得到(100 - 0.39) * 29.75 = 2963.3975 B币。问s币的金额经过交换最终得到的s币金额数能否增加

货币的交换是可以重复多次的,所以我们需要找出是否存在正权回路,且最后得到的s金额是增加的

怎么找正权回路呢?(正权回路:在这一回路上,顶点的权值能不断增加即能一直进行松弛)





题目分析:

一种货币就是图上的一个点

一个“兑换点”就是图上两种货币之间的一个兑换环,相当于“兑换方式”M的个数,是双边

唯一值得注意的是权值,当拥有货币A的数量为V时,A到A的权值为K,即没有兑换

而A到B的权值为(V-Cab)*Rab

本题是“求最大路径”,之所以被归类为“求最小路径”是因为本题题恰恰与bellman-Ford算法的松弛条件相反,求的是能无限松弛的最大正权路径,但是依然能够利用bellman-Ford的思想去解题。

因此初始化d(S)=V 而源点到其他店的距离(权值)初始化为无穷小(0),当s到其他某点的距离能不断变大时,说明存在最大路径

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>

using namespace std;

#define N 1010
#define INF 0x3f3f3f3f
#define PI acos (-1.0)
#define EPS 1e-8

struct node
{
    int a, b;
    double r, c;
}ex[2*N];

int n, m, s, all;//n:货币的种数  m:兑换点总数  s:持有第s种货币
double v, dist
; //持有s货币的本金

int bellman ();

int main ()
{
    while (cin >> n >> m >> s >> v)
    {
        int a, b;
        double rab, cab, rba, cba;
        all = 0;

        for (int i=0; i<m; i++)
        {
            cin >> a >> b >> rab >> cab >> rba >> cba;
            ex[all].a = a, ex[all].b = b, ex[all].r = rab, ex[all++].c = cab;
            ex[all].b = a, ex[all].a = b, ex[all].r = rba, ex[all++].c = cba;
        }

        if (bellman ()) puts ("YES");
        else puts ("NO");
    }
    return 0;
}

int bellman ()
{
    memset (dist, 0, sizeof (dist));
    dist[s] = v;

    int flag;
    for (int i=1; i<=n-1; i++)
    {
        flag = 0;
        for (int j=0; j<all; j++)
            if (dist[ex[j].b] < (dist[ex[j].a] - ex[j].c) * ex[j].r)//寻找最长路径
            {
                dist[ex[j].b] = (dist[ex[j].a] - ex[j].c) * ex[j].r;//进行比较的是“某点到自身的权值”与“某点到另一点的权值”
                flag = 1;
            }

        if (!flag) break;
    }

    for (int i=0; i<all; i++)
        if (dist[ex[i].b] < (dist[ex[i].a] - ex[i].c) * ex[i].r)//正环能够无线松弛
            return 1;
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: