您的位置:首页 > 编程语言 > C语言/C++

HDU 2289 Cup

2015-07-20 14:27 453 查看
Cup
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u

Description

The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height? 

The radius of the cup's top and bottom circle is known, the cup's height is also known.
 

Input

The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases. 

Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water. 

Technical Specification 

1. T ≤ 20. 

2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000. 

3. r ≤ R. 

4. r, R, H, V are separated by ONE whitespace. 

5. There is NO empty line between two neighboring cases. 

 

Output

For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
 

Sample Input

1
100 100 100 3141562

 

Sample Output

99.999024

 

题意

给圆台形杯子的上底圆半径R,下底圆半径r,高度H,和水的体积V,求出水装满杯子后水面的高度。

分析

对水面高度在(0,H)二分,求出对应的体积,和V比较。

附:圆台的体积公式:

,其中r'是上底面半径,r是下底面半径。

(像本人这种数学渣,怎么可能记得这种公式,附给同样渣的朋友。)

AC代码如下

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
#define PI acos(-1.0)
#define exp 1e-9
double solve(double r,double R,double h,double H)
{
double u = h/H*(R-r) + r;
return PI/3*(r*r+r*u+u*u)*h;
}
int main()
{
int t;
double r,R,H,V,mid,vv,f,l;<span style="white-space:pre"> </span>//double型精确度高一点
scanf("%d",&t);
while(t--)
{
scanf("%lf%lf%lf%lf",&r,&R,&H,&V);
f=0;
l=100;
while(l-f>exp)
{
mid=(l+f)/2;
vv=solve(r,R,mid,H);
if(fabs(vv-V)<=exp)
break;
else if(vv>V)
l=mid-exp;
else
f=mid+exp;
}
printf("%.6lf\n",mid);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息