您的位置:首页 > 其它

1+2+3+......+n

2015-07-20 11:33 260 查看
[align=left]Problem Description[/align]
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

[align=left]Input[/align]
The input will consist of a series of integers n, one integer per line.

[align=left]Output[/align]
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

[align=left]Sample Input[/align]

1
100


[align=left]Sample Output[/align]

1

5050


#include<stdio.h>
int main()
{
int i,n,sum;
while(scanf("%d",&n)!=EOF)
{
sum=0;
for(i=1;i<=n;i++)
sum+=i;
printf("%d\n",sum);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: