您的位置:首页 > 其它

Eddy's research I

2015-07-18 21:24 435 查看
Problem Description

Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask
intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

Input

The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

Output

You have to print a line in the output for each entry with the answer to the previous question.

Sample Input

11
9412


Sample Output

11
2*2*13*181

先把65535里面所有的素数都枚举出来,多组输入时查表,凡是能被整除的就输出,对n取整,判断n是否为1,若为1,结束,进行下次循环。

#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<iostream>
#include<string>

using namespace std;

int s(int n)//判断是否为素数
{
int i;
for(i=2; i<=sqrt(n); i++)
if(n%i==0)
return 0;
return 1;
}

int a[60000]={0};
int main()
{
int i,j;
for(i=2,j = 0; i <= 65535; i++)//素数存取
{
if(s(i))
a[j++] = i;
}
a[j]='\0';
int tt=j,n;
while(cin>>n)
{
for(i=0; i<tt;)
{
if(n%a[i]==0)	//判断n是否为素数的倍数,若是,进行以下循环。
{
cout<<a[i];
n=n/a[i];
if(n!=1)	//若n不为1,输出*
{
cout<<"*";
}
if(n==1)	//结束
{
cout<<endl;
break;
}
}
else
i++;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: