您的位置:首页 > 其它

POJ2352 Stars

2015-07-18 10:02 435 查看
B - Stars
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
2352

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5


Sample Output

1
2
1
1
0


Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

/*
Author: 2486
Memory: 604 KB		Time: 391 MS
Language: G++		Result: Accepted
Public:		No
*/
//进行横坐标标注
//题目数据的输入已经确定,是先按照Y坐标升序,当y相等时,按照X坐标升序
//如此,在现在输入的数的X坐标之前已经是满足条件的数即只要是属于此时输入的数的左下角的所有星星个数之和就是他的等级
//通过树状数组可以快速的求解某个区间之前的所有数的和。
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=32000+5;
int A[maxn],B[maxn],n,x,y;
int lowbit(int x) {
return x&(-x);
}
int sum(int x) {
int cnt=0;
while(x>0) {
cnt+=A[x];
x-=lowbit(x);
}
return cnt;
}
void add(int x,int d) {
while(x<maxn) {
A[x]+=d;
x+=lowbit(x);
}
}
int main() {
while(~scanf("%d",&n)) {
memset(B,0,sizeof(B));
memset(A,0,sizeof(A));
for(int i=0; i<n; i++) {
scanf("%d%d",&x,&y);
B[sum(++x)]++;
add(x,1);
}
for(int i=0; i<n; i++)printf("%d\n",B[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: