您的位置:首页 > 其它

uva 10970

2015-07-17 09:41 267 查看
Big Chocolate
Mohammad has recently visited Switzerland . As he loves his friends very much, he decided to buy some chocolate for them, but as this fine chocolate is very expensive(You know Mohammad is a little BIT stingy!), he could only afford buying one chocolate,
albeit a very big one (part of it can be seen in figure 1) for all of them as a souvenir. Now, he wants to give each of his friends exactly one part of this chocolate and as he believes all human beings are equal (!), he wants to split it into equal parts.

The chocolate is an

 rectangle constructed from

 unit-sized
squares. You can assume that Mohammad has also

 friends waiting to receive their piece of chocolate.

To split the chocolate, Mohammad can cut it in vertical or horizontal direction (through the lines that separate the squares). Then, he should do the same with each part separately until he reaches

 unit
size pieces of chocolate. Unfortunately, because he is a little lazy, he wants to use the minimum number of cuts required to accomplish this task.

Your goal is to tell him the minimum number of cuts needed to split all of the chocolate squares apart.

 



Figure 1. Mohammad’s chocolate
 
The Input

The input consists of several test cases. In each line of input, there are two integers

, the number of rows in the chocolate and

,
the number of columns in the chocolate. The input should be processed until end of file is encountered.

 

The Output

For each line of input, your program should produce one line of output containing an integer indicating the minimum number of cuts needed to split the entire chocolate into unit size pieces.

 

Sample Input

2 2

1 1

1 5

 

Sample Output

3

0



Amirkabir University of Technology - Local Contest - Round #2 

题意:给定一个巧克力,问你要怎么切才能切出m*n的巧克力。

思路:题目内容很多,但题目很简单,前面说了很多没用的东西。根据给出的样例分析,可以判断出一次只能将巧克力分成两块,所以切的次数a=M*N-1。

代码:

#include<iostream>
using namespace std;
int main()
{
int M,N;
int sum;
while(cin>>M>>N)
{
sum=M*N-1;
cout<<sum<<endl;
}
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: