您的位置:首页 > 其它

uva 11462 - Age Sort

2015-07-17 09:35 393 查看
11462 - Age Sort

You are given the ages (in years) of all people of a country with at least 1 year of age. You know thatno individual in that country lives for 100 or more years.
Now, you are given a very simple task of

sorting all the ages in ascending order.

Input

There are multiple test cases in the input le. Each case starts with an integer n (0 < n 2000000), the

total number of people. In the next line, there are n integers indicating the ages. Input is terminated

with a case where n = 0. This case should not be processed.

Output

For each case, print a line with n space separated integers. These integers are the ages of that country

sorted in ascending order.

Warning: Input Data is pretty big ( 25 MB) so use faster IO.

Sample Input

5

3 4 2 1 5

5

2 3 2 3 1

0

Sample Output

1 2 3 4 5

1 2 2 3 3

题意:

给定你一组年龄,要你按从小到大排序。

思路:

用sort()函数进行排序即可。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=2000000;
int  a[maxn];
int main()
{
int n;
while(cin>>n&&n!=0)

{
for(int i=0;i<n;i++)
cin>>a[i];
sort(a,a+n);
for(int i=0;i<n-1;i++)
cout<<a[i]<<' ';
cout<<a[n-1];
cout<<endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: