您的位置:首页 > 其它

1008. Elevator (20)

2015-07-15 09:13 441 查看
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbersdenote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.
Sample Input:
3 2 3 1

Sample Output:
41


提交代

——————————

刚刚开始的时候,我没有看到最开始是输入的N,这就导致意思没法理解。

下一次,好好看懂题目。

#include <iostream>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char** argv) {
int N=0;int cur=0,pre=0;
int res=0;
scanf("%d",&N);
while(N--)
{
scanf("%d",&cur);
if(cur>pre)
{
res+=(cur-pre)*6+5;
}
else
{
res+=(pre-cur)*4+5;
}
pre=cur;
}
printf("%d",res);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: