您的位置:首页 > 大数据 > 人工智能

HDU 1239 Calling Extraterrestrial Intelligence Again

2015-07-14 09:50 471 查看
A message from humans to extraterrestrial intelligence was sent through the Arecibo radio telescope in Puerto Rico on the afternoon of Saturday November 16, 1974. The message consisted of 1679 bits and was meant to be translated to
a rectangular picture with 23 * 73 pixels. Since both 23 and 73 are prime numbers, 23 * 73 is the unique possible size of the translated rectangular picture each edge of which is longer than 1 pixel. Of course, there was no guarantee that the receivers would
try to translate the message to a rectangular picture. Even if they would, they might put the pixels into the rectangle incorrectly. The senders of the Arecibo message were optimistic.

We are planning a similar project. Your task in the project is to find the most suitable width and height of the translated rectangular picture. The term "most suitable" is defined as follows. An integer m greater than 4 is given. A positive fraction a / b
less than or equal to 1 is also given. The area of the picture should not be greater than m. Both of the width and the height of the translated picture should be prime numbers. The ratio of the width to the height should not be less than a / b nor greater
than 1. You should maximize the area of the picture under these constraints.

In other words, you will receive an integer m and a fraction a / b. It holds that m > 4 and 0 < a / b < 1. You should find the pair of prime numbers p, q such that pq <= m and a / b <= p / q <= 1, and furthermore, the product pq takes the maximum value among
such pairs of two prime numbers. You should report p and q as the "most suitable" width and height of the translated picture.

[align=left]Input[/align]
The input is a sequence of at most 2000 triplets of positive integers, delimited by a space character in between. Each line contains a single triplet. The sequence is followed by a triplet of zeros, 0 0 0, which indicated the end
of the input and should not be treated as data to be processed. The integers of each input triplet are the integer m, the numerator a, and the denominator b described above, in this order. You may assume 4 < m <= 100000 and 1 <= a <= b <= 1000.

[align=left]Output[/align]
The output is a sequence of pairs of positive integers. The i-th output pair corresponds to the i-th input triplet. The integers of each output pair are the width p and the height q described above, in this order. Each output line
contains a single pair. A space character is put between the integers as a delimiter. No other characters should appear in the output.

[align=left]Sample Input[/align]

5 1 2
99999 999 999
1680 5 16
1970 1 1
2002 4 11
0 0 0


[align=left]Sample Output[/align]

2 2
313 313
23 73
43 43
37 53
p q <= m and a / b <= p / q <= 1;
就是求满足的这条公式  写了这么长………… 还有就是求P*Q为最大 所以要跑完 不能中间就BREAK上面这个代码是优化过的 HD的数据太水了 我们学校的交上去超时了。。。优化一下才能过

#include <stdio.h>
#include <string.h>
int p[10005],pr[2000],i,j;
void pri()
{
bool pre[10000];
memset(p,1,sizeof p);
memset(pre,1,sizeof pre);
pre[1]=0;

for(i=2;i<=5000;i++)
{
if(pre[i]==1)
{
for(j=2;j*i<=10000;j++)
pre[j*i] = 0;
}
}
for(i=1,j=0;i<=10000;i++)
if( pre[i] == 1)
pr[j++] = i;
}

int main()
{
int m,a,b,max,p,q,n;
pri();
n=j;
while(~scanf("%d %d %d",&m,&a,&b),m||a||b)
{

pq <= m and a / b <= p / q <= 1,
max=0;
for(i=n-1;i>=0;i--)
{
for(j=i;j<n;j++)
{
if(pr[i]*pr[j]<=m)
{
if(1.0*a/b<=1.0*pr[i]/pr[j])
{
if(pr[i]*pr[j]>max)
{
p=pr[i];q=pr[j];
max=pr[i]*pr[j];
}
}
}
}
}
printf("%d %d\n",p,q);
}
return 33;
}


[code]#include <stdio.h>
#include <string.h>
int p[10005],sum,pr[2000],i,j;
void pri()
{
memset(p,1,sizeof p);
for(i=2;i<=10000;i++)
for(j=2;j*i<=10000;j++)
p[i*j]=0;
sum=0;
for(i=2;i<=10000;i++)
{
if(p[i])
pr[sum++]=i;
}
}

int main()
{
int m,a,b,max,p,q;
pri();
while(~scanf("%d %d %d",&m,&a,&b),m||a||b)
{
max=0;
double c=1.0*a/b;
for(i=sum-1;i>=0;i--)
{
for(j=sum-1;j>=0;j--)
{
if(pr[i]<=pr[j])
{
if(pr[i]*pr[j]<=m)
{
double d=1.0*pr[i]/pr[j];

if(c<=d)
{
if(pr[i]*pr[j]>max)
{
p=pr[i];q=pr[j];
max=pr[i]*pr[j];//printf("%d %d %lf %lf\n",pr[i],pr[j],c,d);
}
}
}
}
}
}
printf("%d %d\n",p,q);
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: