您的位置:首页 > 其它

HDU 1143 Tri Tiling

2015-07-14 08:55 267 查看
In how many ways can you tile a 3xn rectangle with 2x1 dominoes? Here is a sample tiling of a 3x12 rectangle.



[align=left]Input[/align]
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 ≤ n ≤ 30.

[align=left]Output[/align]
For each test case, output one integer number giving the number of possible tilings.

[align=left]Sample Input[/align]

2
8
12
-1


[align=left]Sample Output[/align]

3
153
2131


可以说是个DP 之前做过两行的 这个三行的做法也差不多
首先 奇数都是0
然后2的时候为3 4的时候,如果不能拆分成2个2的话 就只有2种拆法 6的时候不折成3个2或者1个2 1个4的话 也有两种拆法 8也是这样…………
所以可以算到公式
an=3*an-2+2*(an-4+an-6....)

进一步化简可以得 a[i]=4*a[i-2]-a[i-4];
#include <stdio.h>

int main()
{
int a[40]={0},n,i;
a[0]=1;a[2]=3;
for(i=4;i<32;i+=2)
a[i]=4*a[i-2]-a[i-4];
while(~scanf("%d",&n)&&n!=-1)
printf("%d\n",a
);
return 33;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: