您的位置:首页 > 其它

九度oj 1001

2015-07-13 22:53 357 查看
题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.
输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers
in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.
输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.
样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0

样例输出:
1
5

代码:#include<stdio.h>
#include<stdlib.h>
int main()
{
int a,b,x,y;int m[15][15],n[15][15],z[15][15];
int i,j;
while(scanf("%d%d",&a,&b)!=EOF)
{
if(a==0||b==0)
{
continue;}

for(i=1;i<=a;i++)
{
for(j=1;j<=b;j++)
{
scanf("%d",&x);
m[i][j]=x;
}

}
int k,v;
for(k=1;k<=a;k++)
{
for(v=1;v<=b;v++)
{
scanf("%d",&y);
n[k][v]=y;
}

}
for(i=1;i<=a;i++)
{
for(j=1;j<=b;j++)
{
z[i][j]=m[i][j]+n[i][j];
}
}
int result=0,num=0;
for(i=1;i<=a;i++)
{
for(j=1;j<=b;j++)
{
result+=z[i][j];
}
if(result==0)
{
num++;
}
if(result!=0)
{
result=0;
}
}
for(k=1;k<=b;k++)
{
for(v=1;v<=a;v++)
{
result+=z[v][k];
}
if(result==0)
{
num++;
}
if(result!=0)
{
result=0;
}
}
printf("%d\n",num);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: