您的位置:首页 > 其它

poj 3169 Layout 差分约束

2015-07-13 19:08 316 查看
链接:http://poj.org/problem?id=3169

Layout

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8282Accepted: 3972
Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they
can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other
and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input
4 2 1
1 3 10
2 4 20
2 3 3

Sample Output
27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

题意及做法:

n只牛 ml个最长距离限制,md个最长距离限制

然后输入ml个a,b d , a点和b点距离要小于等于d。 所以b-a<=d这就是差分约束的基本的方程

然后输入md个a,b,d, a点和b点的距离要大于等于d。所以 b-a>=d =》 a-b<=-d

然后又因为 编号小的 放前面 所以 又可以得到 dian(i)- dian(i+1)<=0

把这ml+md+n条差分约束方程 建边,b-a<=d,就建a到b的边距离为d。

如果最短路跑出的是 -inf 说明是有负环,说明 条件矛盾 -1;

如果抛出的inf,说明1和n两点距离可以无穷大。 -2;

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <math.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
#include <stack>
#include <queue>
#include <vector>
#include <deque>
#include <set>
#include <map>

#define VM 30005
#define EM 150005
#define inf 0x7f7f7f7f
int head[VM],ep;
struct edge
{
int v,w,next;
}e[EM];

void addedge(int cu,int cv,int cw)
{
ep ++;
e[ep].v = cv;
e[ep].w = cw;
e[ep].next = head[cu];
head[cu] = ep;
}

int spfa (int n)
{
int vis[VM],stack[VM],dis[VM],vn[VM];
memset(vis,0,sizeof(vis));
memset(dis,0x7f7f7f7f,sizeof dis);
memset(vn,0,sizeof vn);
vn[1]=1;
dis[1] = 0;
vis[1] = 1;
int top = 1;
stack[0] = 1;
while (top)
{
int u = stack[--top];
if(vn[u]>n)
return -inf;
vis[u] = 0;
for (int i = head[u];i != -1;i = e[i].next)
{
int v = e[i].v;
if (dis[v] > dis[u] + e[i].w)
{
dis[v] = dis[u] + e[i].w;
if (!vis[v])
{
vis[v] = 1;
vn[v]++;
stack[top++] = v;
}
}
}
}
return dis
;
}
int main ()
{
int n,m,v1,v2,cost;
int ml,md;
while(scanf("%d%d%d",&n,&ml,&md)!=EOF)
{
ep = 0;
memset (head,-1,sizeof(head));

for(int i=0;i<ml;i++)
{
int u,v,lim;
scanf("%d%d%d",&u,&v,&lim); //v-u<=lim
addedge(u,v,lim);
}

for(int i=0;i<md;i++)
{
int u,v,lim;
scanf("%d%d%d",&u,&v,&lim); //v-u>=lim u-v<=-lim
addedge(v,u,-lim);
}

for(int i=1;i<n;i++)
{
addedge(i+1,i,0);//dian(i)- dian(i+1)<=0
}
int ans=spfa(n);
if(ans==-inf)
puts("-1");//负环 有矛盾条件
else if(ans==inf)//两者可以无线远
puts("-2");
else
printf("%d\n",ans);
}
return 0;
}

/*
4 2 1 1 3 10 2 4 20 2 3 3
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: