您的位置:首页 > 其它

hdu4081 次小生成树变形

2015-07-13 11:54 357 查看
http://acm.hdu.edu.cn/showproblem.php?pid=4081

Problem Description

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other
kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi
Huang" means "the first emperor" in Chinese.



Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:

There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.

Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that
magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible,
but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the
total length of none magic roads.

Would you help Qin Shi Huang?

A city can be considered as a point, and a road can be considered as a line segment connecting two points.

 

Input

The first line contains an integer t meaning that there are t test cases(t <= 10).

For each test case:

The first line is an integer n meaning that there are n cities(2 < n <= 1000).

Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.

It is guaranteed that each city has a distinct location.

 

Output

For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

 

Sample Input

2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40

 

Sample Output

65.00
70.00

 

/**
hdu4081 次小生成树变形
题目大意:给定n个城市,每个城市有ai个人,在这些城市间修路,已知可以免费修一条路,其他路费用为长度,求免费路连接城市人口和修路总费用比值的最大值
解题思路:我们要枚举每条路作为免费路的情况。可以先求出最小生成树sum,如果枚举的边在生成树上就(ai+a[j])/(sum-该边)。如果边不在生成树上
(ai+aj)/(sum-mlen[i][j]) mlen是加上当前边到最小生成树后必然组成的环上除当前边外最大权值边的权值。其实就是一个次小生成树求解
*/
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
const int maxn=1010;
const double inf=1e14;

struct note
{
int x,y,z;
}p[maxn];

double a[maxn][maxn],dis[maxn];
int pre[maxn],n;

int flag[maxn][maxn],vis[maxn];
double mlen[maxn][maxn];

double prim(int u)
{
double sum=0;
memset(flag,0,sizeof(flag));
memset(vis,0,sizeof(vis));
memset(mlen,0,sizeof(mlen));
for(int i=1; i<=n; i++)
{
dis[i]=a[u][i];
pre[i]=u;
}
vis[u]=1;
for(int i=1; i<n; i++)
{
double minn=inf;
int v=-1;
for(int j=1; j<=n; j++)
{
if(!vis[j]&&dis[j]<minn)
{
v=j;
minn=dis[j];
}
}
if(v!=-1)
{
sum+=dis[v];
flag[v][pre[v]]=flag[pre[v]][v]=1;
vis[v]=1;
for(int k=1; k<=n; k++)
{
if(vis[k]&&k!=v)
{
mlen[v][k]=mlen[k][v]=max(mlen[k][pre[v]],dis[v]);
}
if(!vis[k]&&a[v][k]<dis[k])
{
dis[k]=a[v][k];
pre[k]=v;
}
}
}
}
return sum;
}

double lenth(int x,int y,int u,int v)
{
return sqrt((x-u)*(x-u)+(y-v)*(y-v));
}

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(int i=1; i<=n; i++)
{
scanf("%d%d%d",&p[i].x,&p[i].y,&p[i].z);
}
for(int i=1; i<= n; i++)
{
a[i][i]=0;
for(int j=i+1; j<=n; j++)
{
a[i][j]=a[j][i]=lenth(p[i].x,p[i].y,p[j].x,p[j].y);
}
}
double sum=prim(1);
double ans=-1;
for(int i=1; i<=n; i++)
{
for(int j=i+1; j<=n; j++)
{
if(flag[i][j])
ans=max(ans,(p[i].z+p[j].z)/(sum-a[i][j]));
else
ans=max(ans,(p[i].z+p[j].z)/(sum-mlen[i][j]));
}
}
printf("%.2lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: