您的位置:首页 > 其它

杭电 hdu 1033 (水题) 但英文特难,题意很难理解

2015-07-12 15:40 483 查看

Edge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2369    Accepted Submission(s): 1510


[align=left]Problem Description[/align]
For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded
along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts
of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.

After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in
a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming
90 degree turns at equidistant places.

 

[align=left]Input[/align]
The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The
input file terminates immediately after the last test case.

 

[align=left]Output[/align]
For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command "300 420 moveto". The first turn occurs at (310, 420) using the
command "310 420 lineto". Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget
the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.



 

[align=left]Sample Input[/align]

V
AVV

 

[align=left]Sample Output[/align]

300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage

 

[align=left]Source[/align]
University of Ulm Local Contest 2003
 

[align=left]Recommend[/align]
We have carefully selected several similar problems for you:  1035 1036 1039 1017 1073

题意:就是行走,然后输出走过的点,首先给出两个点(300,420)-> (310,420),然后A是顺时针,V是逆时针走,每次行走都是走10个单位,并且

角度是90度,输出每个转弯点

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>
#include <iostream>

using namespace std;

int main ()
{
char ch[300];
int i, len;

while (gets(ch))
{
printf ("300 420 moveto\n");               //最开始的两个点是题目本身就存在的,要先输出
printf ("310 420 lineto\n");
len = strlen (ch);
int x = 300, y = 420, x1 = 310, y1 = 420;       //用前后两个点来标记之后的行走

for (i = 0; i < len; ++i)
{
if (ch[i] == 'V'){                          //逆时针时会遇到的情况
if (x == x1){
if (y1 < y){
x = x1;y = y1;x1 += 10;
}
else{
x = x1;y = y1;x1 -= 10;
}
}
else{
if (x1 > x){
x = x1;y = y1;y1 += 10;
}
else{
x = x1;y = y1;y1 -= 10;
}
}
}
else if (ch[i] == 'A')               //顺时针时会遇到的情况
{
if (x == x1){
if (y1 < y){
x = x1;y = y1;x1 -= 10;
}
else{
x = x1;y = y1;x1 += 10;
}
}
else{
if (x1 > x){
x = x1;y = y1;y1 -= 10;
}
else{
x = x1;y = y1;y1 += 10;
}
}
}
printf("%d %d lineto\n", x1, y1);
}
printf("stroke\nshowpage\n");                     //每一次结束都要输出
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电