您的位置:首页 > 其它

hdu2522

2015-07-11 14:06 429 查看
http://acm.hdu.edu.cn/showproblem.php?pid=2522


A simple problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3600 Accepted Submission(s): 1337



Problem Description

Zty很痴迷数学问题.。一天,yifenfei出了个数学题想难倒他,让他回答1 / n。但Zty却回答不了^_^. 请大家编程帮助他.



Input

第一行整数T,表示测试组数。后面T行,每行一个整数 n (1<=|n|<=10^5).



Output

输出1/n. (是循环小数的,只输出第一个循环节).



Sample Input

4
2
3
7
168




Sample Output

0.5
0.3
0.142857
0.005952380


刚开始我的代码

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
int a[1000005];
int main()
{
    int t,n,k,bo;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        if(n<0)
        {
          printf("-");
          n=-n;
        }
      for(k=0;k<=n*10;k++ )
        a[k]=0;
        k=10;
        printf("0.");
        while(1)
        {
           printf("%d",k/n);
            if(k%n==0||k%n==1)
                break;
            k=(k%n)*10;
            if(a[k])break;
            a[k]++;
        }
        printf("\n");
    }
    return 0;
}
后来我请教了学长
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
int a[1000005];
int main()
{
    int t,n,k,bo;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        if(n<0)
        {
          printf("-");
          n=-n;
        }
      for(k=0;k<=n*10;k++ )
        a[k]=0;
        k=10;
        printf("0.");
        while(1)
        {
           printf("%d",k/n);
            if(k%n==0||k%n==1)//这里k%n==1  break  掉  了
                break;
            k=(k%n)*10;
            if(a[k])break;
            a[k]++;
        }
        printf("\n");
    }
    return 0;


}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: