您的位置:首页 > 其它

POJ 1028:Web Navigation

2015-07-11 10:05 387 查看
Web Navigation

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 30828Accepted: 13821
Description

Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you
are asked to implement this.

The following commands need to be supported:

BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.

FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.

VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.

QUIT: Quit the browser.

Assume that the browser initially loads the web page at the URL http://www.acm.org/ Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time.
The end of input is indicated by the QUIT command.
Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.
Sample Input
VISIT http://acm.ashland.edu/ VISIT http://acm.baylor.edu/acmicpc/ BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/ BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT

Sample Output
http://acm.ashland.edu/ http://acm.baylor.edu/acmicpc/ http://acm.ashland.edu/ http://www.acm.org/ Ignored http://acm.ashland.edu/ http://www.ibm.com/ http://acm.ashland.edu/ http://www.acm.org/ http://acm.ashland.edu/ http://www.ibm.com/
Ignored


水题,题意就是模拟访问网页,看当前网页到了哪里。

代码:

#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
using namespace std;

map <int,string> web;

int main()
{	
	//freopen("input.txt","r",stdin);
	//freopen("out.txt","w",stdout);

	string operate;
	string website;

	int cur=1,zong=1;
	web[1]="http://www.acm.org/";

	while(cin>>operate)
	{
		if(operate=="QUIT")
			break;
		if(operate=="VISIT")
		{
			cin>>website;
			web[++cur]=website;
			zong=cur;
			cout<<website<<endl;
		}
		if(operate=="BACK")
		{
			if(cur==1)
			{
				cout<<"Ignored"<<endl;
			}
			else
			{
				cur--;
				cout<<web[cur]<<endl;
			}
		}
		if(operate=="FORWARD")
		{
			if(cur==zong)
			{
				cout<<"Ignored"<<endl;
			}
			else
			{
				cur++;
				cout<<web[cur]<<endl;
			}
		}
	}

	//system("pause");
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: