您的位置:首页 > 其它

poj 1416 Shredding Company (DFS)

2015-07-10 20:47 441 查看
Shredding Company

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 4595Accepted: 2633
Description

You have just been put in charge of developing a new shredder for the Shredding Company Although a "normal" shredder would just shred sheets of paper into little pieces so that the contents would become unreadable, this new shredder needs to have the following
unusual basic characteristics.

1.The shredder takes as input a target number and a sheet of paper with a number written on it.

2.It shreds (or cuts) the sheet into pieces each of which has one or more digits on it.

3.The sum of the numbers written on each piece is the closest possible number to the target number, without going over it.

For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder would cut the sheet into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (=
1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations without going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the
above combination's 43. The combination of 12, 34, and 6 is not valid either, because the sum 52 (= 12 + 34 + 6) is greater than the target number of 50.



Figure 1. Shredding a sheet of paper having the number 12346 when the target number is 50

There are also three special rules :

1.If the target number is the same as the number on the sheet of paper, then the paper is not cut.

For example, if the target number is 100 and the number on the sheet of paper is also 100, then

the paper is not cut.

2.If it is not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid
combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed.

3.If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are
two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed. In order to develop such a shredder, you have decided to first make a simple program that would simulate the above characteristics and rules.
Given two numbers, where the first is the target number and the second is the number on the sheet of paper to be shredded, you need to figure out how the shredder should "cut up" the second number.

Input

The input consists of several test cases, each on one line, as follows :

tl num1

t2 num2

...

tn numn

0 0

Each test case consists of the following two positive integers, which are separated by one space : (1) the first integer (ti above) is the target number, (2) the second integer (numi above) is the number that is on the paper to be shredded.

Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. You may assume that both integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input.

Output

For each test case in the input, the corresponding output takes one of the following three types :

sum part1 part2 ...

rejected

error

In the first type, partj and sum have the following meaning :

1.Each partj is a number on one piece of shredded paper. The order of partj corresponds to the order of the original digits on the sheet of paper.

2.sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 +...

Each number should be separated by one space.

The message error is printed if it is not possible to make any combination, and rejected if there is

more than one possible combination.

No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line.

Sample Input
50 12346
376 144139
927438 927438
18 3312
9 3142
25 1299
111 33333
103 862150
6 1104
0 0

Sample Output
43 1 2 34 6
283 144 139
927438 927438
18 3 3 12
error
21 1 2 9 9
rejected
103 86 2 15 0
rejected

Source

Japan 2002 Kanazawa

题目链接:http://poj.org/problem?id=1416

题目大意:两个不超过6位的整数n和m,把m拆分开,比如m为123,可以拆成三个数字1,2,3,也可以拆成数字12,3或1,23两个数字等,要求拆分出来的这些数字之和不大于n,求满足条件的最大数字和以及m拆分成哪些数字,如果不能得到答案,输出“error”,如果有多个答案,直接输出“rejeced”。

解题思路:枚举拆分成的小数字的长度,DFS递归过程中累加小数字的和,dfs1搜索满足条件的最大数字和,dfs2记录路径。个人觉得自己写得有些繁琐,用了两次dfs,实在想不出来怎样用一个dfs完成这两个步骤,因为递归过程中要寻找最优解,在不确定最优解的情况下,路径不方便记录。因此第一个dfs得到最优解,第二个dfs在搜索到最优解后原路返回记录路径。

代码如下:

#include <cstdio>
#include <cstring>
int ln,n,ans,cnt;     //ln是整数m的长度,这里用数组a[8]表示整数m
//ans是数字和的最优解,cnt是记录路径时用到的下标
int a[8],path[8],vis[1000000];   //path记录路径,vis用来判断是否存在多个最优解
char s[8];
bool p;               //p标记是否搜索到满足条件的数字和
void dfs1(int st,int sum)   //搜索最优数字和
{
if(st>=ln)              //此时整数m分割成的小数字已全部累加,得到一个数字和的解
{
p=true;
vis[sum]++;         //标记是否存在多个该解值
if(ans<sum)         //找最大解
ans=sum;
return ;
}
for(int i=0;i<ln;i++)    //枚举小数字的长度
{
if(st+i>=ln)
break;
int cur=0;
for(int j=st;j<=st+i;j++)   //st枚举数组起始下标,把各位上的数构造成整数
cur=(cur*10+a[j]);
if(cur+sum>n)              //小数字和大于n,不满足条件,舍去。
break;
dfs1(st+i+1,cur+sum);      //起始下标跳过当前小数字,下一层构造后面一个小数字。
}
}
void dfs2(int st,int sum)    //记录路径
{
if(st>=ln)
{
if(sum==ans)         //找到目标值
p=true;
return;
}
for(int i=0;i<ln;i++)
{
if(st+i>=ln)
break;
int cur=0;
for(int j=st;j<=st+i;j++)
cur=(cur*10+a[j]);
if(cur+sum>n)
break;
dfs2(st+i+1,sum+cur);
if(p)
{
path[cnt++]=cur;   //由后往前记录路径
return;
}
}
}
int main()
{
while(scanf("%d",&n)!=EOF&&n)
{
memset(vis,0,sizeof(vis));
p=false,ans=0,cnt=0;
scanf("%s",s);
ln=strlen(s);
for(int i=0;i<ln;i++)
a[i]=s[i]-'0';
dfs1(0,0);
if(!p)
printf("error\n");
else if(vis[ans]>1)
printf("rejected\n");
else
{
printf("%d",ans);
p=false;
dfs2(0,0);
for(int i=cnt-1;i>=0;i--)
printf(" %d",path[i] );
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: