您的位置:首页 > 其它

find your present (2) 2095

2015-07-10 18:22 435 查看
[align=left]Problem Description[/align]
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

[align=left]Input[/align]
The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

[align=left]Output[/align]
For each case, output an integer in a line, which is the card number of your present.

[align=left]Sample Input[/align]

5
1 1 3 2 2
3
1 2 1
0

[align=left]Sample Output[/align]

3
2

Hint

Hint

use scanf to avoid Time Limit Exceeded

[align=left]Author[/align]
8600

[align=left]Source[/align]
HDU 2007-Spring Programming Contest - Warm Up (1)

[align=left]Recommend[/align]
8600 | We have carefully selected several similar problems for you: 2094 1008 1597 1593 1595

//map
#include <set>
#include <stdio.h>
using namespace std;
int main()
{
int n,x;
set <int> S;
while(scanf("%d",&n),n)
{
while(n--)
{
scanf("%d",&x);
if(S.find(x) == S.end())    //没找到,插入
S.insert(x);
else                        //找到了,删除
S.erase(x);
}
printf("%d\n",*S.begin());
S.clear();
}
return 0;
}


//排序

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cstdlib>
using namespace std;

long long int a[1000010];

int main()
{
int n;
while (scanf("%d",&n) && n)
{
for (int i = 0; i<n; i++)
scanf("%lld",&a[i]);
sort(a, a+n);
int i;
for (i = 1; i<n; i++)
{
if (a[i] != a[i-1]  &&  a[i] != a[i+1])
break;
}
printf("%lld\n",a[i]);
}
return 0;
}


#include <math.h>
#include <string.h>
#include <algorithm>
#include <stdio.h>
long a[100000100];
int main()
{

memset(a,0,sizeof(a));
long n;
while(scanf("%ld",&n)!=EOF&&n!=0)
{
long long m;
for(int i=0;i<n;i++)
{
scanf("%lld",&m);
a[m]+=1;
}
for(int i=0;i<100000100;i++)
{
if(a[i]==1)
{
printf("%lld\n",i);
}
}
}
return 0;
}


其实,这题还有个更好的方法————位异或。

我们先了解一下位异或的运算法则吧:

1、a^b = b^a。

2、(a^b)^c = a^(b^c)。

3、a^b^a = b。

对于一个任意一个数n,它有几个特殊的性质:

1、0^n = n。

2、n^n = 0。

所以可以通过每次异或运算,最后剩下的值就是出现奇数次的那个数字。

#include <stdio.h>
int main()
{
int n,x,ans;
while(scanf("%d",&n),n)
{
ans = 0;
while(n--)
{
scanf("%d",&x);
ans ^= x;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: