您的位置:首页 > 其它

Uva11464 - Even Parity

2015-07-09 10:18 411 查看
We have a grid of size N N. Each cell of the grid initially contains a zero(0) or a one(1). The parity

of a cell is the number of 1s surrounding that cell. A cell is surrounded by at most 4 cells (top, bottom,

left, right).

Suppose we have a grid of size 4 4:

1 0 1 0 The parity of each cell would be 1 3 1 2

1 1 1 1 2 3 2 1

0 1 0 0 2 1 2 1

0 0 0 0 0 1 0 0

For this problem, you have to change some of the 0s to 1s so that the parity of every cell becomes

even. We are interested in the minimum number of transformations of 0 to 1 that is needed to achieve

the desired requirement.

Input

The rst line of input is an integer T (T < 30) that indicates the number of test cases. Each case starts

with a positive integer N (1  N  15). Each of the next N lines contain N integers (0/1) each. The

integers are separated by a single space character.

Output

For each case, output the case number followed by the minimum number of transformations required.

If it's impossible to achieve the desired result, then output `-1' instead.

Sample Input

3

3

0 0 0

0 0 0

0 0 0

3

0 0 0

1 0 0

0 0 0

3

1 1 1

1 1 1

0 0 0

Sample Output

Case 1: 0

Case 2: 3

Case 3: -1

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <queue>
using namespace std;
const int MAXN = 20;
const int MAX = 1<<20;
int n, ans;
int mp[MAXN][MAXN];
struct node{
int x, y;
}q[MAXN*MAXN];
int top;
void dfs(int xb,int select)
{
if(xb==n+1)
{
int temp = select;
bool pd = true;
top = 0;
for(int i=1; pd && i<n; i++)
{
for(int j=1; pd && j<=n; j++)
{
int s = mp[i-1][j] + mp[i+1][j] + mp[i][j+1] + mp[i][j-1];
if(s%2)
{
if(mp[i+1][j]==1)
{
pd = false;
}else{
q[top].x = i+1;
q[top++].y = j;
mp[i+1][j]=1;
temp++;
}
}
}
}
for(int j=1;  pd &&j<=n; j++)
{
int s = mp[n-1][j] + mp[n+1][j] + mp
[j+1] + mp
[j-1];
if(s%2)
{
pd = false;
}
}
if(pd && ans>temp)  ans=temp;
for(int i=0; i<top; i++)
{
mp[q[i].x][q[i].y] = 0;
}
return;
}
if(mp[1][xb]==1)
{
dfs(xb+1,select);
}else{
dfs(xb+1,select);
mp[1][xb] = 1;
dfs(xb+1,select+1);
mp[1][xb] = 0;
}
}
int main()
{
int t, cs, i, j;
scanf("%d",&t);
for(cs=1; cs<=t; cs++)
{
scanf("%d",&n);
memset(mp,0,sizeof (mp));
for(i=1; i<=n; i++)
{
for(j=1; j<=n; j++)
{
scanf("%d",&mp[i][j]);
}
}
ans = MAX;
dfs(1,0);
if(ans==MAX) ans=-1;
printf("Case %d: %d\n",cs,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: