您的位置:首页 > 其它

hdu 1241 Oil Deposits

2015-07-07 22:41 477 查看


Oil Deposits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 16651 Accepted Submission(s): 9576



Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each
plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous
pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following
this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


Sample Output

0
1
2
2


首先,简单的题意是,给你一个矩阵,你的起始位置应该是“@”,让你可以有八个即与你相邻的方向走,只能从“@”到“@”,问你有几次走投无路的情况。

首先想到了一道经典题目:水池数目 http://acm.nyist.net/JudgeOnline/problem.php?pid=27
但是为了稳妥起见,还是用广搜做的。

广搜思路:用两层for 循环,从@开始搜,搜一遍之后再返回, 又从(0,0)开始搜

代码如下:

#include<iostream>
#include<string.h>
#include<math.h>
#include<stdio.h>
#include<algorithm>
#include<queue>
using namespace std;
#define  LL __int64
char a[101][101];
int n,m;
struct node
{
int x,y;
};
int nex[8][2]={0,1,1,0,-1,0,0,-1,-1,1,1,-1,1,1,-1,-1};
void bfs(int x,int y)
{
node cur,now;
cur.x=x,cur.y=y;
queue<node> q;
q.push(cur);
while(!q.empty())
{
cur=q.front();
q.pop();
for(int i=0;i<8;i++)
{
now.x=cur.x+nex[i][0];
now.y=cur.y+nex[i][1];
if(now.x>=0&&now.x<n&&now.y>=0&&now.y<m&&a[now.x][now.y]=='@')
{
a[now.x][now.y]='.';
q.push(now);
}
}
}
return ;
}
int main()
{
while(scanf("%d%d",&n,&m)&&n&&m)
{
for(int i=0;i<n;i++)
scanf("%s",a[i]);
int sum=0;
LI:  for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
if(a[i][j]=='@')
{
a[i][j]='.';
bfs(i,j);
sum++;
goto LI;
}
printf("%d\n",sum);
}
}


深搜的思路和广搜差不多,把每一个点访问一遍就好了:

#include<stdio.h>
#include<algorithm>
using namespace std;
char a[200][200];
int n,m;
int net[8][2]={0,1,1,0,-1,0,0,-1,-1,1,1,-1,1,1,-1,-1};
void dfs(int i,int j)
{
a[i][j]='*';
for(int k=0; k<8; k++)
{
int x=i+net[k][0];
int y=j+net[k][1];
if(x<0||x>=m||y<0||y>=n||a[x][y]=='*')
continue;
dfs(x,y);
}
}
int main()
{
while(scanf("%d%d",&m,&n)&&n&&m)
{
for(int i=0; i<m; i++)
scanf("%s",a[i]);
int sum=0;
for(int i=0; i<m; i++)
for(int j=0; j<n; j++)
if(a[i][j]=='@')
{
dfs(i,j);
//返回这里即意味着已经找完了一处
sum++;
}
printf("%d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: