您的位置:首页 > 其它

poj 2192 Zipper(DFS+剪枝)

2015-07-07 21:29 375 查看
Zipper

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 16825Accepted: 5998
Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat

String B: tree

String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat

String B: tree

String C: catrtee

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two
strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input
3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output
Data set 1: yes
Data set 2: yes
Data set 3: no

Source

Pacific Northwest 2004

题目链接:http://poj.org/problem?id=2192

题目大意:问完全使用两个字符串A,B的字母,能否组成字符串C,组成C串的字母顺序遵从在A,B中的顺序。

解题思路:这题的正解是DP或者记忆化搜索,我用的是DFS+剪枝。两个DFS,一个搜A串,搜索成功后用另一个搜B串。剪枝:1.搜B串时是这样的情况,如果有解,则C串中剩余未搜的字母个数与顺序应该与B串一样,所以第二个搜索不是深搜,而是直接线性判断B,C串对应字母是否一样。2.判断C串最后一个字母是否为A或B串最后一个字母,若不是,直接判断为no。

代码如下:

#include <cstdio>
#include <cstring>
char a[205],b[205],s[410];
int ns,na,nb;
bool q;
void dfsb()
{
int n=0;
for(int i=0;i<ns;i++)
{
if(s[i]=='0')
continue;
if(s[i]!=b
)
return;
n++;
}
q=true;
}
void dfsa(int n,int st)
{
if(q)
return;
if(na==n)
{
dfsb();
return ;
}
for(int i=st;i<ns;i++)
{
if(s[i]==a
)
{
int t=s[i];
s[i]='0';
dfsa(n+1,i+1);
if(q)
return;
s[i]=t;
}
}
}
int main()
{
freopen("in.txt","r",stdin);
int t;
scanf("%d",&t);
for(int ca=1;ca<=t;ca++)
{
q=false;
scanf("%s%s%s", a,b,s);
ns=strlen(s),na=strlen(a),nb=strlen(b);
if(ns!=nb+na||s[ns-1]!=a[na-1]&&s[ns-1]!=b[nb-1])
{
printf("Data set %d: no\n",ca);
continue;
}
dfsa(0,0);
if(q)
printf("Data set %d: yes\n",ca);
else
printf("Data set %d: no\n",ca);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: