您的位置:首页 > 其它

最小生成树

2015-07-06 18:40 239 查看
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2835 Accepted Submission(s): 1377



Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends
are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.

Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length
which the ink draws?

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0


Sample Output

3.41


ac代码:

#include <iostream>

#include <algorithm>

#include <cstdio>

#include <cmath>

using namespace std;

const int N=10005;

double leftt
,rightt
;

//double value
;

int father
,r
;

struct point{

int x,y;

double value;

}aa[10005];

int cmp(const int i,const int j){

return aa[i].value<aa[j].value;

}

int find(int x){

if(father[x]!=x)

father[x]=find(father[x]);

return father[x];

}

int main(){

int n;

while(scanf("%d",&n)!=EOF){

for(int i=0;i<N;++i){

father[i]=i;

r[i]=i;

aa[i].value=0.0;

}

/*for(int i=0;i<10;++i)

{printf("%d ",r[i]);}*/

for(int i=0;i<n;++i){

scanf("%lf%lf",&leftt[i],&rightt[i]);

}

int k=0;

for(int i=0;i<n;++i){

for(int j=0;j<n;++j){

if(i!=j)

{aa[k].value=sqrt((leftt[i]-leftt[j])*(leftt[i]-leftt[j])+(rightt[i]-rightt[j])*(rightt[i]-rightt[j]));

aa[k].x=i;

aa[k].y=j;

k++;

}

}

}

//printf("k===%d\n",k);

/*for(int i=0;i<k;++i)

{printf("%d ",r[i]);}*/

sort(r,r+k,cmp);

/*for(int i=0;i<k;++i)

{printf("%d ",r[i]);}

printf("\n");*/

double sum=0;

for(int i=0;i<k;++i){

int e=r[i];

int x=find(aa[e].x);

int y=find(aa[e].y);

if(x!=y){

sum+=aa[e].value;

/*printf("x==%d\n y==%d\n",x,y);

printf("sum===%.2lf\n",sum);*/

father[x]=y;

}

}

printf("%.2lf\n",sum);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: