您的位置:首页 > 移动开发 > IOS开发

A Mathematical Curiosity(坑水题)

2015-07-04 19:45 483 查看


A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 31228 Accepted Submission(s): 10004



Problem Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.



Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.



Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.



Sample Input

1

10 1
20 3
30 4
0 0




Sample Output

Case 1: 2
Case 2: 4
Case 3: 5




Source

East Central North America 1999, Practice



Recommend

JGShining | We have carefully selected several similar problems for you: 1018 1005 1021 1019 1032

题目没有算法,直接枚举就可以,不过这个输入的要求有点奇葩,以前没见过这样的。一直没明白过来到底是什么意思,写完直接交了直接WA,斗争很久就是交不上,看了一个前辈的一句话,才知道是这样....

代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int n,m;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int k = 0;
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            if(n == 0 && m == 0)
            {
                break;
            }
            int cnt = 0;
            for(int i=1; i<n; i++)
            {
                for(int j=i+1; j<n; j++)
                {
                    if((i*i + j*j + m)%(i*j) == 0)
                    {
                        cnt++;
                    }
                }
            }
            printf("Case %d: %d\n",++k,cnt);

        }
        if(T)
        {
            printf("\n");
        }
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: