您的位置:首页 > 其它

The Suspects-并查集(4)

2015-07-04 14:34 423 查看
C - The Suspects
Time Limit:1000MS Memory Limit:20000KB 64bit IO Format:%I64d & %I64u
Submit Status

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there
are many student groups. Students in the same group intercommunicate
with each other frequently, and a student may join several groups. To
prevent the possible transmissions of SARS, the NSYSU collects the
member lists of all student groups, and makes the following rule in
their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the
suspects when a student is recognized as a suspect. Your job is to write
a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two
integers n and m in a line, where n is the number of students, and m is
the number of groups. You may assume that 0 < n <= 30000 and 0
<= m <= 500. Every student is numbered by a unique integer between
0 and n−1, and initially student 0 is recognized as a suspect in all
the cases. This line is followed by m member lists of the groups, one
line per group. Each line begins with an integer k by itself
representing the number of members in the group. Following the number of
members, there are k integers representing the students in this group.
All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0


Sample Output

4
1
1


#include <cstdio>
int pa[300000],a,n,num[100000];
int cha(int k)
{
if(pa[k]!=k)
{
pa[k]=cha(pa[k]);
}
return pa[k];
}
bool bing(int x,int y)
{
int x2=cha(x);
int y2=cha(y);
if(x2==y2)
return false;
pa[y2]=x2;//把他们都连在一起
num[x2]+=num[y2];//num用作累计结点个数
return true;
}
void  init(int n)
{
for(int i=0; i<=n; i++)
{
pa[i]=i;
num[i]=1;
}
return ;
}
int main()
{
int m,n,k,t;
while(scanf("%d%d",&n,&m))
{
init(n);
if(m+n==0)
{
break;
}
for(int i=0; i<m; i++)
{
scanf("%d",&k);
scanf("%d",&t);
for(int j=1; j<k; j++)
{
scanf("%d",&a);
bing(t,a);
}
}
printf("%d\n",num[cha(0)]);//查出祖宗为0的结点个数
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: