您的位置:首页 > 其它

POJ 1163 The Triangle

2015-07-02 21:24 295 查看
The Triangle

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 40354Accepted: 24340
Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle,
all integers, are between 0 and 99.
Output

Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30


自底向上的求解方法
#include <stdio.h>
int main()
{
int n;
scanf("%d", &n);
int i, j;
int tr[105][105], max[105][105];
for(i = 1; i <= n; i++)
for(j = 1; j <=i; j++)
scanf("%d", &tr[i][j]);
for(i = n, j = 1; j <= i; j++)
max[i][j] = tr[i][j];
for(i = n; i >= 1; i--)
for(j = 1; j <= i; j++)
{
if(max[i][j] > max[i][j+1])
max[i-1][j] = max[i][j] + tr[i-1][j];
else
max[i-1][j] = max[i][j+1] + tr[i-1][j];
}
printf("%d\n", max[1][1]);
return 0;
}


还不太懂什么是DP,别人的代码。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int max[105][105], tr[105][105];
int n;
int maxsum(int x, int y)
{
if(x == n)
return tr[x][y];
if(max[x+1][y] == -1)
max[x+1][y] = maxsum(x+1, y);
if(max[x+1][y+1] == -1)
max[x+1][y+1] = maxsum(x+1, y+1);
if(max[x+1][y] > max[x+1][y+1])
return max[x+1][y] + tr[x][y];
else
return max[x+1][y+1] + tr[x][y];
}

int main()
{
int i, j;
scanf("%d", &n);
memset(max, -1, sizeof(max));
for(i = 1; i <= n; i++)
for(j = 1; j <= i; j++)
scanf("%d", &tr[i][j]);
printf("%d", maxsum(1,1));
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: