您的位置:首页 > 其它

ZOJ Problem Set - 1414||Number Steps

2015-06-30 20:27 239 查看
Number Steps

Time Limit: 2 Seconds Memory Limit: 65536 KB

Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and
(3, 1) respectively and this pattern has continued.



You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the
range 0...5000.

Input

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

Output

For each point in the input, write the number written at that point or write No Number if there is none.

Sample Input

3

4 2

6 6

3 4

Sample Output

6

12

No Number

Source: Asia 2000, Tehran (Iran)

#include <stdio.h>
int main()
{
int n, x, y, result;
scanf("%d", &n);
while(n--)
{
scanf("%d %d", &x, &y);
if(x == y)
{
if(x % 2 == 0)
result = x + y;
else
result = x + y - 1;
printf("%d\n", result);
}
else if(x - 2 == y)
{
if(y % 2 == 0)
result = x + y;
else
result = x + y - 1;
printf("%d\n", result);
}
else
printf("No Number\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: