您的位置:首页 > 其它

HDU 1312Red and Black dfs

2015-06-30 13:18 344 查看

Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12117 Accepted Submission(s): 7543

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move
only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.



Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)



Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).



Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0




Sample Output
45
59
6
13




Source
Asia 2004, Ehime (Japan), Japan Domestic



Recommend
Eddy | We have carefully selected several similar problems for you: 1241 1016 1010 1372 1242
AC代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
int tu[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
char dfs[22][22];
int t1,t2,n,m,sum;
void fun(int x,int y){
    sum++;
    dfs[x][y]='#';
    for(int i=0;i<4;++i){
        int dx=x+tu[i][0];
        int dy=y+tu[i][1];
        if(dx<n&dy<m&&dx>=0&&dy>=0&&dfs[dx][dy]=='.'){
            fun(dx,dy);
        }
    }
    return ;
}
int main(){
    int i,j;
    char c;
    while(cin>>m>>n&&(n|m)){
        for(i=0;i<n;++i){
            for(j=0;j<m;++j){
                cin>>dfs[i][j];
                if(dfs[i][j]=='@'){
                    t1=i;
                    t2=j;
                }
            }
        }
         sum=0;
        fun(t1,t2);
        cout<<sum<<'\12';
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: