您的位置:首页 > 其它

[POJ 2461] Billiard

2015-06-24 17:19 246 查看
同swustoj 11
Billiard

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 1362Accepted: 842
Description

In a billiard table with horizontal side a inches and vertical side b inches, a ball is launched from the middle of the table. After s > 0 seconds the ball returns to the point from which it was launched, after having made m bounces off the vertical sides and n bounces off the horizontal sides of the table. Find the launching angle A (measured from the horizontal), which will be between 0 and 90 degrees inclusive, and the initial velocity of the ball.
Assume that the collisions with a side are elastic (no energy loss), and thus the velocity component of the ball parallel to each side remains unchanged. Also, assume the ball has a radius of zero. Remember that, unlike pool tables, billiard tables have no pockets.
Input

Input consists of a sequence of lines, each containing five nonnegative integers separated by whitespace. The five numbers are: a, b, s, m, and n, respectively. All numbers are positive integers not greater than 10000.
Input is terminated by a line containing five zeroes.
Output

For each input line except the last, output a line containing two real numbers (accurate to two decimal places) separated by a single space. The first number is the measure of the angle A in degrees and the second is the velocity of the ball measured in inches per second, according to the description above.
Sample Input

100 100 1 1 1
200 100 5 3 4
201 132 48 1900 156
0 0 0 0 0

Sample Output

45.00 141.42
33.69 144.22
3.09 7967.81

题意:一个长宽分别为ab的矩形桌子中间有一个球,朝着某个方向以某个速度发射出去,在s时间恰好与水平方向碰撞n次,垂直方向碰撞m次,求发射角度与速度。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f3f
#define PI acos(-1.0)

int main()
{
int n,m;
double a,b,s;
while(scanf("%lf%lf%lf%d%d",&a,&b,&s,&m,&n)!=EOF)
{
if(a+b+s+m+n==0) break;
double angel=atan2(b*n,a*m)*180/PI;
double v=sqrt(a*a*m*m+b*b*n*n)/s;
printf("%.2f %.2f\n",angel,v);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: