您的位置:首页 > 其它

POJ2155:Matrix(二维树状数组,经典)

2015-06-24 14:11 363 查看
/article/2388776.html

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).

2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1


Sample Output
1
0
0
1


Source

POJ Monthly,Lou Tiancheng

这道题确实很经典,尤其在这个二进制的计算方面

详细的可以参考《浅谈信息学竞赛中的“0”和“1”》此论文,网上很多说的并不详细,大多只介绍了翻转,并没有介绍为何sum(x,y)%2能得到结果

论文里很详细的证明了

http://download.csdn.net/detail/lenleaves/4548401

[cpp] view
plaincopy

#include <iostream>

#include <stdio.h>

#include <string.h>

#include <string>

#include <stack>

#include <queue>

#include <map>

#include <set>

#include <vector>

#include <math.h>

#include <bitset>

#include <list>

#include <algorithm>

#include <climits>

using namespace std;

#define lson 2*i

#define rson 2*i+1

#define LS l,mid,lson

#define RS mid+1,r,rson

#define UP(i,x,y) for(i=x;i<=y;i++)

#define DOWN(i,x,y) for(i=x;i>=y;i--)

#define MEM(a,x) memset(a,x,sizeof(a))

#define W(a) while(a)

#define gcd(a,b) __gcd(a,b)

#define LL long long

#define N 1005

#define INF 0x3f3f3f3f

#define EXP 1e-8

#define lowbit(x) (x&-x)

const int mod = 1e9+7;

int c

,n,m,cnt,s,t;

int a

;

int sum(int x,int y)

{

int ret = 0;

int i,j;

for(i = x;i>=1;i-=lowbit(i))

{

for(j = y;j>=1;j-=lowbit(j))

{

ret+=c[i][j];

}

}

return ret;

}

void add(int x,int y)

{

int i,j;

for(i = x;i<=n;i+=lowbit(i))

{

for(j = y;j<=n;j+=lowbit(j))

{

c[i][j]++;

}

}

}

int main()

{

int i,j,x,y,ans,t;

int x1,x2,y1,y2;

char op[10];

scanf("%d",&t);

while(t--)

{

scanf("%d%d",&n,&m);

MEM(c,0);

MEM(a,0);

while(m--)

{

scanf("%s",op);

if(op[0]=='C')

{

scanf("%d%d%d%d",&x1,&y1,&x2,&y2);

x1++,y1++,x2++,y2++;

add(x2,y2);

add(x1-1,y1-1);

add(x2,y1-1);

add(x1-1,y2);

}

else

{

scanf("%d%d",&x1,&y1);

x2 = x1,y2 = y1;

x1++,y1++,x2++,y2++;

printf("%d\n",sum(x1,y1));

}

}

printf("\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: