您的位置:首页 > 其它

hdoj 1058 Humble Numbers 【好题】

2015-06-22 22:56 302 查看


Humble Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19926 Accepted Submission(s): 8694



Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence



Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.



Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.



Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0




Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.



输出好坑。。。

#include<stdio.h>
#include<string.h>
#define max 5843
int humble[max];
int min(int x,int y)
{
    return x<y?x:y;
}
int main()
{
    int n,i,j,k;
    int a2,a3,a5,a7;
    int p2,p3,p5,p7;
    humble[1]=1;p2=p3=p5=p7=1;
    for(i=2;i<max;i++)
    {
        a2=humble[p2]*2;
        a3=humble[p3]*3;
        a5=humble[p5]*5;
        a7=humble[p7]*7;
        humble[i]=min(min(a2,a3),min(a5,a7));
        if(humble[i]==a2)
        {
            p2++;
        }
        if(humble[i]==a3)
        {
            p3++;
        }
        if(humble[i]==a5)
        {
            p5++;
        }
        if(humble[i]==a7)
        {
            p7++;
        }
    }
    while(scanf("%d",&n)&&(n!=0))
    {
        k=n%100;//最后两位 
        if(k>=10&&k<=20)
        {
            printf("The %dth humble number is %d.\n",n,humble
);
            continue;
        }
        k=n%10;
        printf("The %d",n);
        if(k==1)
        printf("st ");
        else if(k==2)
        printf("nd ");
        else if(k==3)
        printf("rd ");
        else
        printf("th ");
        printf("humble number is %d.\n",humble
);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: