您的位置:首页 > 其它

浙江大学PAT_甲级_1084. Broken Keyboard (20)

2015-06-21 09:07 288 查看
题目链接:点击打开链接

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital
numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.
Sample Input:
7_This_is_a_test
_hs_s_a_es

Sample Output:
7TI

这题以前写过。
链接:点击打开链接

我的c++程序:

#include<iostream>
#include<string>
#include<array>
using namespace std;
int main()
{
int i = 0,j=0,n=0;
string first, second;//first应该的字符串,second实际输入的字符串
array<char, 80> result;//漏掉的字符
cin >> first>>second;
while (i < first.size())//小写转大写
{
if (first[i] >= 'a'&&first[i] <= 'z')
{
first[i] = first[i] - 32;
}
i++;
}
while (j< second.size())//小写转大写
{
if (second[j] >= 'a'&& second[j] <= 'z')
{
second[j] = second[j] - 32;
}
j++;
}
i = 0,j=0;
for (auto p : first)
{
if (second.find(p) == -1)//在实际输入的字符串里查找漏掉的的字符,没找到返回-1
{
result.at(i)=p;//把漏掉的字符串添加进result数组
i++;
}
}
n = i;
for (i = 0; i <n;i++)//把重复的字符串标记为'*'
{
for (j = i+1; j < n; j++)
{
if (result[i] == result[j])
{
result[j] = '*';
}
}
}
for (i = 0; i <n; i++)
{
if (result[i] != '*')//输出不重复的字符
{
cout << result[i];
}
}
//system("pause");
return 0;
}


python程序:
l=raw_input()
k=raw_input()
re=""
s=[]
s1=[]
for i in l:
if i.upper() not in s:
s.append(i.upper() )
for i in k:
if i.upper() not in s1:
s1.append(i.upper() )
for i in s:
if i not in s1:
re=re+i
print re

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: