您的位置:首页 > 其它

浙江大学PAT_甲级_1065. A+B and C (64bit) (20)

2015-06-20 17:45 369 查看
题目链接:点击打开链接

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).
Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:
Case #1: false
Case #2: true
Case #3: false

我的python2程序:

n=int(raw_input())
num=[]
for i in range(1,n+1):
num=[int(j) for j in raw_input().split()]
if num[0]+num[1]>num[2]:
print "Case #%d: true"%(i)
else:
print "Case #%d: false"%(i)



=======

2015.7.13

java

import java.util.*;
import static java.lang.System.*;
import java.math.*;
public class Main
{
public static void main(String[] args)
{
Scanner cin=new Scanner(System.in);
BigInteger a=BigInteger.valueOf(1);
BigInteger b=BigInteger.valueOf(1);
BigInteger c=BigInteger.valueOf(1);
int n=0;
n=cin.nextInt();
for(int i=0;i<n;i++)
{
a=cin.nextBigInteger();//输入大数字a
b=cin.nextBigInteger();//输入大数字b
c=cin.nextBigInteger();//输入大数字c
a=a.add(b);//a=a+b;
if(a.compareTo(c)>0)
{
out.println("Case #"+(i+1)+": true");
}
else
{
out.println("Case #"+(i+1)+": false");;
}
}
}
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: