您的位置:首页 > 其它

POJ 2229 Sumsets

2015-06-20 13:42 375 查看
Sumsets

Time Limit: 2000MS Memory Limit: 200000K

Total Submissions: 14323 Accepted: 5699

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1

2) 1+1+1+1+1+2

3) 1+1+1+2+2

4) 1+1+1+4

5) 1+2+2+2

6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

这道题就属于找规律的题了,在场上遇到这种题,很容易就放弃了,因为没有思路,这时候就采用打表的方式去做题,当着这道题计算机不能计算,得手算,得到结果之后看到规律。

#include <iostream>
#include <cstdio>
using namespace std;
int a[1000005];
int main(void)
{
a[1]=1;
for(int i=2;i<=1000000;i++)
{
if(i%2==0)
a[i]=a[i-1]+a[i/2];
else
a[i]=a[i-1];
a[i]%=1000000000;
}
int n;
scanf("%d",&n);
printf("%d\n",a
);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: