您的位置:首页 > 其它

HDU-1251

2015-06-19 21:37 363 查看

统计难题

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 21814 Accepted Submission(s): 9297


[align=left]Problem Description[/align]
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

[align=left]Input[/align]
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

[align=left]Output[/align]
对于每个提问,给出以该字符串为前缀的单词的数量.

[align=left]Sample Input[/align]

banana

band

bee

absolute

acm

ba

b

band

abc

[align=left]Sample Output[/align]

2
3
1
0

[align=left]Author[/align]
Ignatius.L

/**
题意:如题
做法:trie树 G++ MLE了n次 C++ AC 与AC自动机建树相同
**/
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include <cmath>
using namespace std;
struct node
{
int Count;
node *next[26];
node()
{
memset(next,NULL,sizeof(next));
Count = 0;
}
};
node *p,*root = new node();
void Insert(char *s)
{
int i,k;
for(p = root,i=0; s[i]; ++i)
{
k = s[i] -'a';
if(p->next[k] == NULL) p->next[k] = new node();
p = p->next[k];
p->Count++;
}
}
int Search(char *s)
{
int i,k;
for(p = root,i=0; s[i]; i++)
{
k = s[i] -'a';
if(p->next[k] == NULL) return 0;
p = p->next[k];
}
return p->Count;
}
int main()
{
//#ifndef ONLINE_JUDGE
//          freopen("in.txt","r",stdin);
//#endif
char s[20];
root = new node();
while(1)
{
cin.getline(s,20);
if(strcmp(s,"") == 0) break;
Insert(s);
}
int tt = 0;
while(1)
{
cin.getline(s,20);
if(strcmp(s,"") == 0) break;
printf("%d\n",Search(s));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: