您的位置:首页 > 其它

浙江大学PAT_甲级_1036. Boys vs Girls (25)

2015-06-16 15:20 531 查看
题目链接:点击打开链接

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters
with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM.
If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:
Mary EE990830
Joe Math990112
6

Sample Input 2:
1
Jean M AA980920 60

Sample Output 2:
Absent
Jean AA980920
NA

C++程序:
#include<iostream>
#include<string>
using namespace std;
int main()
{
int n;//人数
int i = 0,j=0;
//name_gender_subject[i][0]第i个人的姓名,name_gender_subject[i][1]第i个人的性别,name_gender_subject[i][1]第i个人的ID
string name_gender_subject[10000][3];
int grade,max_Fgrade=0,min_Mgrade=100;// grade分数,max_Fgrade女生的最高分,min_Mgrade男生的最低分
string F_name,M_name;//F_name最高分女生的姓名+空格+ID
cin >> n;
for (;i < n;i++)
{
cin >> name_gender_subject[i][0] >> name_gender_subject[i][1] >> name_gender_subject[i][2] >> grade;
if (name_gender_subject[i][1] == "F")//是女生
{
if (grade >= max_Fgrade&&grade<=100)//记录女生里的最高分
{
F_name = name_gender_subject[i][0] + ' ' + name_gender_subject[i][2];
max_Fgrade = grade;
}
}
else//是男生
{
if (grade <= min_Mgrade&&grade>=0)//记录男生里的最低分
{
M_name = name_gender_subject[i][0] + ' ' + name_gender_subject[i][2];
min_Mgrade = grade;
}
}
}
if (F_name.size() == 0)//没有女生最高分
{
cout << "Absent" << endl;
cout << M_name << endl;
cout << "NA";
}
if (M_name.size() == 0)
{
cout << F_name << endl;
cout << "Absent" << endl;
cout << "NA";
}
if (M_name.size() != 0 && F_name.size() != 0)
{
cout << F_name << endl;
cout << M_name << endl;
cout << max_Fgrade - min_Mgrade;
}
//system("pause");
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: