您的位置:首页 > 其它

浙江大学PAT_甲级_1027. Colors in Mars (20)

2015-06-16 09:29 519 查看
题目链接:点击打开链接

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference
is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.
Sample Input
15 43 71

Sample Output
#123456

The only difference is that they use radix 13 (0-9 and A-C) instead of 16.

唯一的区别是,他们使用的,而不是16基数13(0-9和AC)。

输入的数字要转换为13进制。
C++程序:

#include<iostream>
#include<string>
using namespace std;
void transform(int num)
{
char c[3] = { 'A','B','C' };
if (num / 13 >= 10)// num / 13商数
{
cout << c[num / 13 - 10];
}
else
{
cout << num / 13;
}
if (num % 13 >= 10)// num % 13 余数
{
cout << c[num % 13 - 10];
}
else
{
cout << num % 13;
}
}
int main()
{
int a, b, c;
cin >> a >> b >> c;
cout << '#';
transform(a);
transform(b);
transform(c);
//system("pause");
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: