您的位置:首页 > 其它

hdoj 1977 Consecutive sum II

2015-06-15 22:21 357 查看

Consecutive sum II

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2523 Accepted Submission(s):
1219


[align=left]Problem Description[/align]
Consecutive sum come again. Are you ready? Go
~~
1 = 0 + 1
2+3+4 = 1 + 8
5+6+7+8+9 = 8 + 27

You can
see the consecutive sum can be representing like that. The nth line will have
2*n+1 consecutive numbers on the left, the first number on the right equal with
the second number in last line, and the sum of left numbers equal with two
number’s sum on the right.
Your task is that tell me the right numbers in the
nth line.

[align=left]Input[/align]
The first integer is T, and T lines will
follow.
Each line will contain an integer N (0 <= N <=
2100000).

[align=left]Output[/align]
For each case, output the right numbers in the Nth
line.
All answer in the range of signed 64-bits integer.

[align=left]Sample Input[/align]

3

0

1

2

[align=left]Sample Output[/align]

0 1
1 8

8 27

找规律

#include<stdio.h>
#include<string.h>
int main()
{
long long m,n;
scanf("%lld",&n);
while(n--)
{
scanf("%lld",&m);
printf("%lld %lld\n",m*m*m,(m+1)*(m+1)*(m+1));
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: