您的位置:首页 > 其它

UVA11988:Broken Keyboard (a.k.a. Beiju Text)

2015-06-15 09:48 357 查看
You’re typing a long text with a broken keyboard. Well it’s not so badly broken. The only problem with

the keyboard is that sometimes the “home” key or the “end” key gets automatically pressed (internally).

You’re not aware of this issue, since you’re focusing on the text and did not even turn on the

monitor! After you finished typing, you can see a text on the screen (if you turn on the monitor).

In Chinese, we can call it Beiju. Your task is to find the Beiju text.

Input

There are several test cases. Each test case is a single line containing at least one and at most 100,000

letters, underscores and two special characters ‘[’ and ‘]’. ‘[’ means the “Home” key is pressed internally,

and ‘]’ means the “End” key is pressed internally. The input is terminated by end-of-file (EOF).

Output

For each case, print the Beiju text on the screen.

Sample Input

This_is_a_[Beiju]_text

[[]][][]Happy_Birthday_to_Tsinghua_University

Sample Output

BeijuThis_is_a__text

Happy_Birthday_to_Tsinghua_University

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <list>
#include <algorithm>
#include <climits>
using namespace std;

#define lson 2*i
#define rson 2*i+1
#define LS l,mid,lson
#define RS mid+1,r,rson
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 100005
#define MOD 1000000007
#define INF 0x3f3f3f3f
#define EXP 1e-8
#define lowbit(x) (x&-x)

char str
;
int next
;

int main()
{
    int i,j,cur,last;
    while(gets(str+1))
    {
        int len = strlen(str+1);
        cur = last = 0;
        next[0] = 0;
        for(i = 1; i<=len; i++)
        {
            if(str[i]=='[') cur = 0;
            else if(str[i]==']') cur = last;
            else
            {
                next[i] = next[cur];
                next[cur] = i;
                if(last == cur) last = i;
                cur = i;
            }
        }
        for(i = next[0]; i; i = next[i])
            printf("%c",str[i]);
        puts("");
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: