您的位置:首页 > 其它

Flying to the Mars(map容器)

2015-06-14 17:15 260 查看


Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 12960 Accepted Submission(s): 4110



Problem Description



In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF
convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got
wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that
is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student
is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the
broomstick needed .

For example :

There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;

One method :

C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.

D could teach E;So D E are eligible to study on the same broomstick;

Using this method , we need 2 broomsticks.

Another method:

D could teach A; So A D are eligible to study on the same broomstick.

C could teach B; So B C are eligible to study on the same broomstick.

E with no teacher or student are eligible to study on one broomstick.

Using the method ,we need 3 broomsticks.

……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.



Input

Input file contains multiple test cases.

In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)

Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);



Output

For each case, output the minimum number of broomsticks on a single line.



Sample Input

4
10
20
30
04
5
2
3
4
3
4




Sample Output

1
2



找重复次数最多的那个

为什么要这样呢?因为重复的那几个数必须在不同的魔法少把中

如果他的重复次数最多那么最大的最小的跟他在一块是不占用额

外的少把的!就是这样!

还要注意的就是我用cin超时了,改成scanf就可以了,下次也需

要注意了!

#include<cstdio>
#include<iostream>
#include<map>
using namespace std;
int main()
{
    int n,v,maxs;
    while(scanf("%d",&n)!=EOF)
    {
        maxs=-155;
        map<int,int>m;//第一个为关键字,第二个为关键字的值
        while(n--)
        {
            scanf("%d",&v);
            m[v]++;
        }
        for(map<int,int>::iterator it=m.begin();it!=m.end();it++)
        {
            if(it->second>maxs)
            {
                maxs=it->second;
            }
        }
        cout<<maxs<<endl;
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: