您的位置:首页 > 其它

HDU--1164

2015-06-13 09:20 232 查看


Eddy's research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7402    Accepted Submission(s): 4479


Problem Description

Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write
a program which can do the number to divided into the multiply of prime number factor .

 

Input

The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

 

Output

You have to print a line in the output for each entry with the answer to the previous question.

 

Sample Input

11
9412

 

Sample Output

11
2*2*13*181

 

Author

eddy

#include <iostream>
using namespace std;

int main()
{
int n;
while (cin >> n)
{
for (int i=2; i<=n; i++)
{
if (n %i==0)
{
n = n/i;
if (n==1)
cout << i<< endl;
else
cout << i<< "*";
i= 1;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: