您的位置:首页 > 其它

LA3027:Corporative Network(并查集)

2015-06-10 22:03 274 查看
A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the

corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon, for

amelioration of the services, the corporation started to collect some enterprises in clusters, each of them

served by a single computing and telecommunication center as follow. The corporation chose one of the

existing centers I (serving the cluster A) and one of the enterprises J in some cluster B (not necessarily the

center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I

J|(mod 1000). In such a way the two old clusters are joined in a new cluster, served by the center of the old

cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving

center could be changed and the end users would like to know what is the new length. Write a program to

keep trace of the changes in the organization of the network that is able in each moment to answer the

questions of the users.

Input

Your program has to be ready to solve more than one test case. The first line of the input file will contains

only the number T of the test cases. Each test will start with the number N of enterprises (5≤N≤20000). Then

some number of lines (no more than 200000) will follow with one of the commands:

E I asking the length of the path from the enterprise I to its serving center in the moment;

I I J informing that the serving center I is linked to the enterprise J.

The test case finishes with a line containing the word O. The I commands are less than N.

Output

The output should contain as many lines as the number of E commands in all test cases with a single number

each the asked sum of length of lines connecting the corresponding enterprise with its serving center.

Sample Input

1

4

E 3

I 3 1

E 3

I 1 2

E 3

I 2 4

E 3

O

Sample Output

0

2

3

5

题意:

有n个节点,有两个操作

I x y:把x作为y的子节点连上,他们的距离为abs(x-y)%1000

E x:查询x到根节点的距离

思路:

节点数这么多我们当然不可能在询问的时候再去累加距离了,所以我们必须开一个数组来记录节点到根节点的距离,在并查集的过程中同时更新距离

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <algorithm>
#include <climits>
using namespace std;

#define LS 2*i
#define RS 2*i+1
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 100005
#define MOD 1000000007
#define INF 0x3f3f3f3f
#define EXP 1e-8

int father
;
int dis
;

int find(int x)
{
    if(father[x]==x)
        return father[x];

    int root = find(father[x]);
    dis[x]+=dis[father[x]];
    return father[x] = root;
}

int ads(int x)
{
    return x<0?-x:x;
}

int main()
{
    int t,x,y,i,j,n;
    char str[10];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i = 0; i<=n; i++)
        {
            father[i] = i;
            dis[i] = 0;
        }
        while(scanf("%s",str))
        {
            if(str[0]=='O')
                break;
            if(str[0]=='E')
            {
                scanf("%d",&x);
                find(x);
                printf("%d\n",dis[x]);
            }
            if(str[0]=='I')
            {
                scanf("%d%d",&x,&y);
                father[x]=y;
                dis[x]=ads(x-y)%1000;
            }
        }
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: