您的位置:首页 > 其它

HDU 1390 Binary Numbers

2015-06-10 21:34 351 查看
题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=1390

题目描述:

Binary Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2834 Accepted Submission(s): 1758

Problem Description

Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0.

Example

The positions of 1's in the binary representation of 13 are 0, 2, 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.

Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

Output

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.

[align=left]Sample Input[/align]

1
13

Sample Output

0 2 3

题意:

输出2进制数位为1的位置,从低到高。

题解:

这题主要注意两点:
1、二进制的低位高位问题(与10进制是de一样),11110000;1是高位,0是低位
2、注意格式问题,第一个余数为1的输出 "%d" ,其余后序余数为1的输出 " %d",空格不对会出Presentation Error错误

#include <iostream>
using namespace std;

int main(void)
{
int n,j;
int num;

cin>>n;
while(n--)
{
j=0;
cin>>num;
while(num>0)
{
if(num%2==1&&num/2==0)
{
cout<<j;
}else if(num%2==1&&num/2>0)
{
cout<<j<<" ";
}

num/=2;
j++;
}
cout<<endl;
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: