您的位置:首页 > 其它

渣渣ACM日记——1013-Digital Roots (HDOJ)

2015-06-10 10:44 417 查看

Digital Roots

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 57658 Accepted Submission(s): 18000



[align=left]Problem Description[/align]
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are
summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

[align=left]Input[/align]
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

[align=left]Output[/align]
For each integer in the input, output its digital root on a separate line of the output.

[align=left]Sample Input[/align]

24
39
0


[align=left]Sample Output[/align]

6
3
//刚开始做用Int存初始数据被坑了 ,题目没说多长的数,所以用一个字符串来保存 假设字符串一亿个,每个都是9,第二次也不会超出Int ,所以后面不用转换成字符串
#include <iostream>
#include <string>
using namespace std;
int main(){
int j;
string s;
while(cin>>s){
if(s=="0")
break;
int i=0;
for(j=0;s[j]!='\0';j++)
i+=s[j]-'0';
if(i<10)
cout<<i<<endl;
else {
int tmp=i;
while(tmp>9){
i=tmp;
tmp=0;
while(i!=0){
tmp+=i%10;
i/=10;
}
}
cout<<tmp<<endl;
}
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: