您的位置:首页 > 其它

Uva - 10340 - All in All

2015-06-09 16:56 323 查看
You have devised a new encryption technique which encodes a message by inserting between its

charac- ters randomly generated strings in a clever way. Because of pending patent issues we will

not discuss in detail how the strings are generated and inserted into the original message. To

validate your method, however, it is necessary to write a program that checks if the message is

really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can

remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII

characters separated by whitespace. Input is terminated by EOF.

Output

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence person compression

VERDI vivaVittorioEmanueleReDiItalia caseDoesMatter CaseDoesMatter

Sample Output

Yes No Yes

No

遍历一遍对比求解即可,注意这里不能用scanf输入两个字符串,会出现RE或者TLE

AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>

using namespace std;
char s[100005], t[100005];
int main()
{

while (cin >> s >> t) {
int bingo = 0;
int nS = strlen(s);
int nT = strlen(t);
int i = 0;
if (nS <= nT) {
for (int j = 0; j < nT; j++) {
if (t[j] == s[i]) {
bingo++;
i++;
}
}
if (bingo == nS) {
printf("Yes\n");
}
else {
printf("No\n");
}
}
else {
printf("No\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: