您的位置:首页 > 其它

HDU--2114

2015-06-08 17:04 190 查看


Calculate S(n)

Time Limit: 10000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8905 Accepted Submission(s): 3257



Problem Description

Calculate S(n).

S(n)=13+23 +33 +......+n3 .

Input

Each line will contain one integer N(1 < n < 1000000000). Process to end of file.

Output

For each case, output the last four dights of S(N) in one line.

Sample Input

1
2


Sample Output

0001
0009


Author

天邪

#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
long long int n;
while (cin >> n)
{
long long int result;
result = ((n * (n+1) / 2) %10000) * ((n * (n+1) /2) %10000) %10000;
printf("%04lld\n",result);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: