您的位置:首页 > 其它

HDU 1050 Moving Tables

2015-06-07 23:54 274 查看


Moving Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 23044 Accepted Submission(s): 7749



Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.



Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains
two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.



Output

The output should contain the minimum time in minutes to complete the moving, one per line.



Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50




Sample Output

10
20
30




#include <stdio.h>
#include <algorithm>
#include <cstring>
using namespace std;

int main()
{
    int T,N;
    int c[401];
    while (scanf("%d", &T)!=EOF)
    {
        while (T--)
        {
            scanf("%d", &N);        
            int a,b;
            int max = -1;
            memset(c, 0, sizeof(c));
            for(int i=0; i<N; i++)
            {
                scanf("%d %d", &a, &b);
                //将区间限制为从小到大地移动桌子 
                if (a > b)
                {
                    swap(a, b);
                }
                //由于走廊两边的排列都是奇数与偶数相对,而任何一个要移动,
                //都会影响对面的不能被使用,也就是shared
                //所以,如果是偶数开始,那么会影响到对面的,也就是a-1
                //同理,如果是奇数结束,也会影响到对面的,也就是b+1
                //那么在这个区间都是被shared的 
                if (a%2 == 0)
                    a--;
                if (b%2 == 1)
                    b++;
                for (int i=a; i<=b; i++)
                {
                    //标记被shared的区间[a, b],被使用一次加一次,所以是c[i]++ 
                    c[i]++;
                    //找重叠数最大之一,即必须经过的次数 
                    if (c[i]>max)
                        max = c[i];
                }
            }               
            printf("%d\n", max*10);
        }                
    }    
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: