您的位置:首页 > 其它

UVA - 572---Oil Deposits.

2015-06-07 20:59 387 查看
基础搜索题,用深搜即可。不小心WA了几次,输入的时候把长和宽弄反了— —!

Description





The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land
into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.
A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how
many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise

and

.
Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ` *', representing the absence of oil, or ` @', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


Sample Output

0
1
2
2


Miguel A. Revilla

1998-03-10

#include<cstdio>
#include<cmath>
#include<iostream>
#include<string.h>
#include<cstdlib>

using namespace std;

int W , H;
char a[110][110];

void dfs(int x ,int y)
{
    a[x][y] = '*';

    for(int dx = -1; dx <= 1 ; dx++)
    {
        for(int dy = -1; dy <= 1; dy++)
        {
            int nx = dx + x;
            int ny = dy + y;

            if(nx >= 0 && nx < H && ny >= 0 && ny < W && a[nx][ny] == '@')
            {
                dfs(nx, ny);
//                printf("%d %d\n",nx, ny);
            }
        }
    }
    return;
}

int main()
{
    while(scanf("%d %d", &H, &W) != EOF)
    {
        if(!H && !W)
            break;
        int cnt = 0;
        for(int i = 0 ; i < H ; i++)
            scanf("%s", a[i]);
//        for(int i = 0 ; i < H ; i++)
//            puts(a[i]);
        for(int i = 0; i < H ; i++)
        {
            for(int j = 0; j < W; j++)
            {
                if(a[i][j] == '@')
                {
                    dfs(i ,j);
                    cnt++;
                }
            }
        }
        cout<<cnt<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: