您的位置:首页 > 其它

Milking Time

2015-06-07 20:16 357 查看
Milking Time

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5667Accepted: 2365
Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri <ending_houri ≤ N),
and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending
hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that
Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: N, M, and R

* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output
43


#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int M=1000005;
const int N=1005;
struct ac
{
    int start,en_d,eff;
}data
;
bool cmp(ac a,ac b)
{
    if(a.start!=b.start)
        return a.start<b.start;
    else
        return a.en_d<b.en_d;
}
long dp
;
int main()
{
    int m,n,r;
    cin>>m>>n>>r;
     for(int i=1;i<=n;i++){
      scanf("%d%d%d",&data[i].start,&data[i].en_d,&data[i].eff);
      data[i].en_d+=r;
     }
      sort(data+1,data+n+1,cmp);
     for(int i=1;i<=n;i++){
         dp[i]=data[i].eff;//一大开始时我有时间挤奶啊,都要啊
         for(int j=1;j<i;++j){
            if(data[j].en_d<=data[i].start)//从i返回到开始时,若当前开始时间大于前面的时间段的结束时间了
               dp[i]=max(dp[i],dp[j]+data[i].eff);//我就要当前dp 和当前价值+do[j]的和的大的值
         }
     }
     //然而并不一定是最后那个收尾!!!
     int maxx=-9;
     for(int i=1;i<=n;i++)
        if(dp[i]>maxx)
        maxx=dp[i];
      cout<<maxx<<endl;
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: